Issue Accessing New Hires in ApplicantStack Onboard
Incident Report for Swipeclock
Resolved
This issue has been resolved and all known affected accounts have been verified as working. Thank you for your patience. Have a wonderful weekend. - SwipeClock Technical Support
Posted Jul 10, 2020 - 14:28 MDT
Identified
We have identified the root cause of this issue and are working quickly to get it resolved.
Posted Jul 10, 2020 - 13:57 MDT
Investigating
We are aware of and investigating reports of users being unable to access new hire records in the ApplicantStack Onboard application. We have all hands on deck looking in to the issue and will provide updates as information becomes available. Thank you for your patience.
Posted Jul 10, 2020 - 13:55 MDT
This incident affected: ApplicantStack Onboard.