Scheduled Maintenance Notice – ApplicantStack

Scheduled for Apr 7, 18:00 - 20:00 MDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 27, 2026 - 11:22 MDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 07, 2026 - 18:00 MDT

Scheduled

ApplicantStack will be undergoing scheduled maintenance on March 31 at 6:00 PM MTN.

This release includes system updates focused on enhanced validation rules and overall performance improvements. During this time, the system will be unavailable for approximately 2 hours.

We recommend avoiding any time-sensitive work in ApplicantStack during this maintenance window.

We will provide an update once the release is complete and service has been fully restored.
Posted Apr 07, 2026 - 17:45 MDT
This scheduled maintenance affects: ApplicantStack Recruit and ApplicantStack Onboard.