www3.Swipeclock.com Redirect Issue
Incident Report for Swipeclock
Resolved
The redirecting issue with www3.swipeclock.com has been resolved. If the issue persists, please clear your browser cache.

Thank you,
Swipeclock Technical Support
Posted Jan 12, 2023 - 09:15 MST
Identified
The main Swipeclock marketing site, www3.swipeclock.com is currently redirecting to applicantstack.com, our applicant tracking application marketing site. We understand that many employees and managers use the www3.swipeclock.com site to reach a login link for our timekeeping applications. All applications are up and running, and users can access login to timekeeping and WebClock applications using the following links;
Employee - https://clock.payrollservers.us/#/clock/web/login
Manager - https://payrollservers.us/pg/login.aspx (edited)

We have identified the issue causing the redirect and expect to have it resolved within the hour. Propagation of the update may take some time and we will continue to provide updates here.

Thank you for your patience.

Swipeclock Technical Support
Posted Jan 12, 2023 - 08:28 MST
This incident affected: TimeWorks, TimeWorksPlus, Webclock, and Office Infrastructure.