Product Issue Notice – WorkforceHub Site Creation & Scheduling

Incident Report for Swipeclock

Resolved

This incident has been resolved.
Posted Jun 26, 2026 - 14:31 MDT

Update

Product Issue Update – Resolved

Status: Resolved

Engineering has identified and resolved the issue affecting WorkforceHub site creation and Employee Scheduling synchronization.

Resolution
New WorkforceHub sites are now being created successfully without errors.
Employee additions and updates are now being properly reflected in Scheduling.

The issue began at approximately 7:30 A.M. MT. Engineering implemented a fix, and the resolution has been successfully tested and validated.

We appreciate your patience while our team worked to resolve this issue. If you continue to experience any related problems, please contact Support or your Account Manager directly.
Posted Jun 26, 2026 - 14:29 MDT

Update

We are continuing to investigate this issue.
Posted Jun 26, 2026 - 12:07 MDT

Investigating

Product Issue Notice – WorkforceHub Site Creation & Scheduling

Status: Investigating
We are currently investigating an issue affecting the creation of new WorkforceHub sites, which is causing any newly added employees not to appear in Scheduling. We believe this issue started around late evening yesterday or early morning- please monitor employees added over this time period.

Current Impact
-Resellers are currently unable to create new WorkforceHub Plus, Essentials, Advanced, and WorkforceHub V1 sites.
-Additionally, any employees added during this time will not appear on the Scheduling calendar. (all products listed)

Known Cause
Our investigation indicates the issue is related to the provisioning of the TimeSimplicity (Scheduling) component of a site.
The initial WorkforceHub site may be created successfully; however, an error occurs when the system attempts to provision the TimeSimplicity Scheduling environment.

Workaround
There is no known workaround at this time.

Next Steps
Our Engineering team is actively investigating the issue and working toward a resolution. We will provide additional updates as soon as more information becomes available, including an estimated resolution time. Based on current progress, we are optimistic that the issue will be resolved within the next few hours.
Posted Jun 26, 2026 - 12:07 MDT
This incident affected: TimeWorksPlus, TimeSimplicity, WorkforceHUB, and WorkforceHUB API.