Email Provider Issues - TimeWorksPlus, TimeSimplicity, ApplicantStack, WorkforceHub
Incident Report for Swipeclock
Resolved
This incident has been resolved.
Posted Feb 01, 2023 - 07:49 MST
Monitoring
Outbound emails in all systems are now operational. Emails in the applications were queued and are sending out at this time. It may take some time for all queued emails to send, but they are going out now. We will continue to monitor the performance of the email system throughout the day to ensure all issues have been resolved.
We appreciate your patience.
-Swipeclock Technical Support
Posted Jan 31, 2023 - 07:50 MST
Identified
Our email provider is working on a resolution to this issue. We will continue to provide updates as we receive information.
-Swipeclock Technical Support
Posted Jan 30, 2023 - 20:45 MST
Investigating
The email provider used by Swipeclock's applications is experiencing a service interruption. As such, no emails are currently being sent out to users from the following applications; TimeWorksPlus, WorkforceHub, TimeSimplicity, ApplicantStack Recruit and OnBoard. Our team is in touch with our provider and we will post updates here as information becomes available. You need not open cases with Technical Support as we are aware of the situation. We appreciate your patience.
-Swipeclock Technical Support
Posted Jan 30, 2023 - 18:07 MST
This incident affected: TimeWorks, TimeWorksPlus, TimeSimplicity, WorkforceHUB, ApplicantStack Recruit, and ApplicantStack Onboard.