Incident Resolved Time: Approximately 8:20 AM MT Current Status: Resolved
The issue was identified as related to an AWS service disruption. Our teams worked quickly to monitor the situation and confirm full service restoration across impacted systems.
All previously impacted services, including WorkforceHub (WFH), TimeWorksPlus (TWP), mobile applications, and integrations, are now functioning normally.
We will continue to monitor system performance to ensure stability. If you experience any lingering issues, please contact our support team.
Thank you for your patience and partnership.
Posted Mar 24, 2026 - 08:29 MDT
Investigating
We are currently experiencing a widespread service disruption impacting multiple Swipeclock products.
Start Time: Approximately 6:15 AM MT
What’s Impacted: WorkforceHub (WFH) TimeWorksPlus (TWP) Mobile Applications Integrations
What’s Currently Available: TimeSimplicity (standalone) HUB (standalone) ApplicantStack
Our teams are actively investigating and working to restore full functionality as quickly as possible.
We understand the urgency of these disruptions and the impact on your operations. We will continue to provide updates as more information becomes available.
Thank you for your patience, and we appreciate your partnership.
Posted Mar 24, 2026 - 07:13 MDT
This incident affected: TimeWorks, TimeWorksPlus, Clocks, Webclock, TimeWorks Mobile, TimeSimplicity Mobile, TimeWorksPlus API, TimeSimplicity API, WorkforceHUB, WorkforceHUB API, and TimeWorksPlus Employee Mobile Application.